Database interface and PostgreSQL driver for R This package provides a Database Interface (DBI) compliant driver for R to access PostgreSQL database systems. In order to build and install this package from source, PostgreSQL itself must be present your system to provide PostgreSQL functionality via its libraries and header files. These files are provided as postgresql-devel package under some Linux distributions. On Microsoft Windows system the attached libpq library source will be used. A wiki and issue tracking system for the package are available at Google Code at https://code.google.com/p/rpostgresql/ .

Documentation

Manual: RPostgreSQL.pdf
Vignette: None available.

Maintainer: Tomoaki Nishiyama <tomoakin at staff.kanazawa-u.ac.jp>

Author(s): Joe Conway, Dirk Eddelbuettel, Tomoaki Nishiyama, Sameer Kumar Prayaga (during 2008), Neil Tiffin

Install package and any missing dependencies by running this line in your R console:

install.packages("RPostgreSQL")

Depends R (>= 2.9.0), methods, DBI(>=0.1-4)
Imports
Suggests
Enhances
Linking to
Reverse
depends
BIEN, rpostgis, rpostgisLT, RRedshiftSQL, timeseriesdb
Reverse
imports
dbfaker, postGIStools, sejmRP, taxizedb, TSPostgreSQL, tweet2r
Reverse
suggests
dplyr, etl, PivotalR, ProjectTemplate, sf, spacetime, sqldf, TSdata
Reverse
enhances
sqlutils
Reverse
linking to

Package RPostgreSQL
Materials
URL https://code.google.com/p/rpostgresql/ http://www.stat.bell-labs.com/RS-DBI http://www.postgresql.org
Task Views
Version 0.4-1
Published 2016-05-08
License GPL-2 | file LICENSE
BugReports
SystemRequirements
NeedsCompilation yes
Citation
CRAN checks RPostgreSQL check results
Package source RPostgreSQL_0.4-1.tar.gz