Support for simple features, a standardized way to encode spatial vector data. Binds to GDAL for reading and writing data, to GEOS for geometrical operations, and to Proj.4 for projection conversions and datum transformations.

Maintainer: Edzer Pebesma <edzer.pebesma at uni-muenster.de>

Author(s): Edzer Pebesma*, Roger Bivand*, Ian Cook*, Tim Keitt*, Michael Sumner*, Robin Lovelace*, Hadley Wickham*, Jeroen Ooms*, Etienne Racine*

Install package and any missing dependencies by running this line in your R console:

install.packages("sf")

Depends R (>= 3.3.0)
Imports utils, stats, tools, graphics, grDevices, grid, methods, Rcpp, DBI(>=0.5), units(>=0.4-6), magrittr
Suggests geosphere(>=1.5-5), maptools, maps, rgdal, rgeos, sp(>=1.2-4), RSQLite, RPostgreSQL, lazyeval, tibble, rlang, ggplot2, dplyr(>=0.7-0), tidyr(>=0.7-0), testthat, knitr, microbenchmark
Enhances
Linking to Rcpp

Package sf
Materials
URL https://github.com/r-spatial/sf/
Task Views Spatial
Version 0.5-4
Published 2017-08-28
License GPL-2 | MIT + file LICENSE
BugReports https://github.com/r-spatial/sf/issues/
SystemRequirements GDAL (>= 2.0.0), GEOS (>= 3.3.0), PROJ.4 (>= 4.8.0)
NeedsCompilation yes
Citation
CRAN checks sf check results
Package source sf_0.5-4.tar.gz